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1 Introduction 
The SB-USB2 emulator enables efficient and productive embedded software 
debugging.  This compact and portable probe utilizes the JTAG interfaces 
for debug and in-circuit testing supplied with VeriSilicon’s ZSP cores.  It 
integrates well with VeriSilicon’s ZView Integrated Development 
Environment (IDE) supporting all stages of ZSP debugging and 
development.  The emulator supports unlimited software breakpoints within 
all ranges of program memory implemented in RAM.   
 
1.1 Features 
The SB-USB2 has the following features: 

• Powered by USB port 
• JTAG interface 
• Logic Levels: 3.3V, 2.5V, 1.8V  
• TCK: 32kHz - 10MHz  
• Integrates with VeriSilicon’s ZViewIDE 

 
1.2 Package Contents 
The SB-USB2 ships with the following: 

• Emulator 
• USB cable 
• Drivers for MS Windows 
• Installation Guide 

 
 
For more information contact Domain Technologies or see 
www.domaintech.com. 

http://www.domaintech.com/
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2 Installation 
Included with the SB-USB2 emulator is a 6-ft. USB cable, 24 pin to 10/14 pin 
ribbon cable and an installation CD. Verify all have been delivered with the 
emulator.   

The installation CD contains a number of executables and DLLs; these enable 
the SB-USB2 emulator to operate with VeriSilicon’s ZView Integrated 
Development Environment (IDE) and  ZSP development tools.  In addition, the 
CD contains sample code for ZSP400 and ZSP500, and the JTAG BSDL files.  
The software installation should be executed before connecting USB emulator to 
the system. The installation procedure provides information about location of the 
USB drivers, so Windows can find them automatically. 

Insert the installation CD into your CD ROM drive.  If auto detect is enabled 
in your system environment setup, then the installation program will 
automatically launch.  Otherwise, double-click the DtiZspInstall.exe file located 
on the CD drive from within Windows Explorer.  Follow the steps through 
the installation program to perform a complete or partial install of the SB-
USB2 supporting software. 
 

3 Integration with VeriSilicon’s Toolset 
The SB-USB2 emulator can be used with either VeriSilicon’s ZViewIDE or 
the non-graphical Debugging tool set.  To properly activate the debug 
interface, the appropriate command line parameters must be specified when 
using ZDBUG.EXE. The initial JTAG TCK operating frequency can be set 
with the MDI command, after the debugger is started, and before the target 
processor is stopped with the TARGET JTAG command. SB-USB2 
provides three different VCC levels for different target types. The output 
voltage can be changed with the MDI command, but since the driver is 
trying to detect connected devices during program initialization, VCC level 
should be set through the environment variable before program is started: 

SET SBUSB2_VCC=level 
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Where level can be 33, 25 or 18 for output levels of 3.3V, 2.5V or 1.8V. For 
the 5V targets - 3.3V configuration can be used. 
 

3.1 Command Line Parameters 
The following command line parameters are supported with ZDBUG.EXE: 
 

Parameter Description 
--mdi_library=mdisbusb2 Direct (non-TCP/IP) connection to the emulator.  

Provides a universal interface that detects the target ZSP 
type by the value of the JTAG’s IDCODE or by 
measuring the length of the EX JTAG register. 

--mdi_library= mdiserver TCP/IP connection to the emulator 
 
For direct (non-TCP/IP) connection to the SB-USB2 JTAG emulator the 
following command line parameter should be used: 

--mdi_library=mdi sbusb2 

For a remote TCP/IP connection to the SB-USB2 JTAG emulator, the IP 
address of the remote computer must be stored in the environment variable 
EMU_SERVER.  Use the following option to indicate a remote connection: 

--mdi_library=mdiserver 

To set the environment variable EMU_SERVER, execute the following 
command from a DOS window: 

set EMU_SERVER=server_address 
where server_address  can be any format recognized by the operating system. 
 
Optionally, the environment variable can also be set by using the System 
Properties Window found in Microsoft’s Control Panel; through the 
Advanced Tab, environment variables can be created and modified. 
 
The target access can fail in case of invalid version of the monitor code in the 
evaluation board’s flash memory. A Flash update is possible with the 
Boundary Scan Programming procedure described at: 
 

http://www.domaintec.com/zspflash.html

http://www.domaintec.com/zspflash.html
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3.2 MDI Commands 
These MDI commands are supported after the target board is initialized 
through ZDBUG.EXE: 

MDI Command Description 
benchclear [0|1] Set/get benchmark clear on start 
benchcont [0|1 Enable continuous benchmark counting during active control 
benchctrl [pin] Set/get benchmark control pin (1..24)   
benchmark [0|1] Set/get benchmark active level 
benchmark [mode] Get benchmark counter (1-abs, 2-dif, 3-both) 
benchsw [0|1] Eenable SW benchmark mode 
break [0|1] Enable/disable breakpoint callback logic   
bvlog [filename|off] Enables/disables detailed logging feature; used to document 

a problem with the SB-USB2 JTAG emulator 
bvlogmdi [0|1] Control MDI function call logging feature 
bvlogusb [0|1] Control low level USB logging feature   
dconfig addr ncsramload DCache configuration address 
dis_ice Disable hardware emulation mode 
en_ice Enable hardware emulation mode 
fastdrupdate [val] Enables fast transition through the JTAG’s UpdateDr state, 

during issue of ADI request (stop in software emulation 
mode). When enabled, the SB-USB2  issues 8 clocks with 
TMS set high, causing the JTAG state machine to go from 
Pause-DR, through Update-DR, to TestLogic/Reset, and 
then to RunTest/Idle. Default TCK frequency  is 3 MHz, 
and is controlled with the next parameter between 6 MHz 
and 100 kHz. Only use if the HWFLAG register is cleared 
during the ADI request (stop in software emulation mode). 

iconfig addr ncsramload ICache configuration address 
idcode Read device's IDCODE JTAG register 
jtag Change JTAG state or shift bits 
mapfile [name] Assign map filename for hardware emulation mode 
measure Measure hardware scan length; verifies MAP file matches 

target device. 
memcache [0|1] Control memory caching option 
memcachesize [num] Set size of memory cache buffer (1..24)   
reset Performs hardware reset for the target 
tck [val] Set or get emulators delay counter to slow down the JTAG 

TCK operation   The default value is 1041 kHz. The 
frequency value can be entered in format n [MHz|kHz|]: 

mdi tck 8 MHz 
mdi tck 32 kHz 
mdi tck 320000 

TCK value will be set to the closes available frequency. 
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trst Send JTAG’s TRST command to the target 
vcc [val] Set/Get current output level. Valid options are 33, 25 and 18. 
version Reports emulator revision information 
zsptype type Specify device type: ZSP400, ZSP410, ZSP420, ZSP500, 

ZSP520 
 
3.3 Sample SDEBUG Session 
Several sample programs are supplied on the SB-USB2 JTAG installation CD.  
The following sample debug session will demonstrate the procedure using 
SDBUG to debug sample program DEMOSINE400.OUT.   The SB-USB2 
JTAG is connected via the USB port to the PC, and connected through its 
ribbon cable to the target board.  In this example the target board is Domain 
Technologies’ DT402EB. 

1. Using a Dos Window, enter the following command to start the 
debugger from the directory containing the sample application.  By 
default the sample applications are placed in \ZSPTools\ZSP400. 

>sdbug –mdi_library=mdizu400 demosine400.out 

In the above example, the interface type is set by using the mdizu400 
command line parameter: 

2. At the debugger prompt type: 

<sdbug> mdi ?   

 A list of the supported MDI commands will be displayed. 
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3. Multiple ZSP JTAG targets are possible, but for the purpose of this 
example, a single target is used.  Connect the debugger to the first target 
by using the following command: 

<sdbug> target jtag 1 

 Upon completion, the start address, load size, and transfer rate will be 
displayed: 

 

 

4. The debugger session is now ready for actions like setting a breakpoint, 
examining data, viewing the stack, etc.  Refer to VeriSilicon’s 
documentation or utilize the help command to continue this debug 
session: 
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3.4 ZView IDE  
VeriSilicon’s ZView Integrated Development Environment (IDE) features a 
high level language ZSP target debugger as part of the Eclipse software 
development environment. Eclipse is an open, industry-supported, 
extensible, software development platform. Programmers create, test and 
debug applications with fast data access and extensive display capabilities. A 
typical debugging environment consists of the ZView IDE running on a 
host, the host connected to any Domain Technologies’ emulator, and the 
emulator connected to the target ZSP. 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The SB-USB2 emulator can be used with ZView IDE when developing for more 
complex configurations such as debugging with multiple users, multiple ZSP 
targets, or remote access.  This is done through the use of ZServer connectivity 
software which is shipped with ZView IDE.  This multi-core/device connectivity 
capability allows the user to start/stop/single-step selected devices 
simultaneously.   Access to multiple devices is provided from single or multiple 
workstations via TCP/IP connection. 
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3.5 Sample ZView IDE Debug Session 
Several sample programs are supplied on the installation CD.  The following  will 
demonstrate the procedure using ZViewIDE to debug sample project Demosine..  
The SB-USB2 is connected via the USB port to the PC, and connected through 
its ribbon cable to the target board.  In this example the target board is Domain 
Technologies’ DT402EB. 

1. Run ZView IDE.  Double click on the Demosine folder in the 
Navigator window. The folder will expand to reveal the project 
contents.  Double click on the Demosine.c file. An Edit window will be 
opened for file demosine.c: 

2. The DemoSine project was built automatically by the ZView IDE. This 
feature is enabled through the project's properties.  The Console 
Window displays the results of the build operation. To display the 
Console window, choose menu option Window->Show View->Console.  

3. Use the ZView IDE's Debug Perspective to enable and control the 
display windows for debugging the sample project. To change the 
perspective choose Window->Open Perspective->DSP Debug or select the 
DSP Debug perspective from the icon bar.   
The Debug perspective will show the Debug, Variable, Breakpoints, 
Expressions, Memory, Graph, ZView Console, Stderr, and Stdout windows 
for your project. 

4. Define and connect the hardware target; in this example it will be the 
DT402EB. To connect, choose the menu option DSP->Open Connection. 
Select the Interface Type: SB-USB2-ZSP .  Select required operating 
voltage levels. Emulator can operate with different pin out modes, but 
for standard ZSP connections the “auto” can be selected. 
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Select the Query button to automatically populate the Target Select field 
based upon the connected device.  Select OK to initialize.  

 

 

 

 

 

 

 

 

 

 

 
Note, if the connected target device does not have known JTAG 
IDCODE to identify it, use JTAG command to configure JTAG 
scan chain. The Query button only allows auto configuration of 
known devices. 

 
By starting the ZServer software, ZViewIDE supports debugging of 
remote targets.  In the Open Connection dialog, choose radio button 
TCP/IP and specify the server’s IP Address.  The Query and Setup 
buttons can be used to define the Target. For additional information 
on the Open Connection function, review the online help by 
selecting Help->Contents from the ZViewIDE main Window. 

5. The DemoSine sample project has a debug session already configured; 
the configuration is named DemoSine.  Select menu option Run-
>Debug followed by the named debug configuration; for this example 
choose DemoSine. When the debugger is started, the application will 
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stop at the entry to the main function. Local variables are not 
initialized yet, since the functions pre-amble was not executed: 

 

 

 

 

 

6. To set a breakpoint, right click with the mouse in the margin of the 
source window; choose toggle breakpoint from the displayed list.  
The Breakpoints window will be updated with the new breakpoint, the 
breakpoint symbol will be visible in the source window, and the code 
window will highlight the active breakpoint.  Once all desired 
breakpoints have been set, users may control the debugger behavior 
through the IDE’s Run menu option. 

4 ZSP500 Initialization without Monitor Code  
The SB-USB2 can load the ZSP500 without ROM monitor code.  In order to 
accomplish the load, users need an application with an interrupt vector 
including a debug interrupt that contains the debug monitor.  The monitor 
code for software debugging must have an interrupt vector table configured 
at instruction memory address 0x0000. 

The following sections will describe the procedure for ZDBUG.EXE and 
VeriSilicon’s ZViewIDE Debugger to: 

• Invoke the debugger 
• Set the register mapfile 
• Enable hardware debug mode 
• Load the program image with the debug monitor 
• Set UVT bit in %smode 
• Turn off hardware debug mode and debug in normal mode 
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4.1 Steps Using ZDBUG 
In the following steps, the user program IMAGE.OUT will be used as the 
application with an interrupt vector including a debug interrupt that contains the 
debug monitor.  The monitor code for software debugging has an interrupt 
vector table configured at instruction memory address 0x0000. 

1. In a DOS Window, invoke ZDBUG.EXE with the appropriate 
command line parameter to identify the target ZSP: 

<zdbug> –-mdi_library=mdisbusb2 image.out 

2. Set the register map file as shown below: 
<zdbug> mdi mapfile <mapfile of the chip> 

3. Enable hardware debug mode with the following command: 
<zdbug> mdi en_ice 

4. Connect the debugger to the target board by issuing this command: 
<zdbug> target jtag  

5. Load the monitor image with the following command: 
<zdbug> load 

6. Set %smode’s UVT bit as shown: 
<zdbug> set $smode=0x80 

7. Turn off hardware debug mode with the following command: 
<zdbug> hw return_to_sw_dbg 

8. Continue debugging as normal. 

4.2 Steps Using ZViewIDE  
1. Run ZViewIDE: 

• Open your project.   
• Change to a  Debug Perspective  

2. Initialize the connection to your G2 target: 
• Select DSP ->Open Connection from the main window  
• Set Interface Type to “SBUSB2”   
• Select Query to populate the Target Select field  
• Select OK to initialize your G2 target 
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3. With a Debug Configuration, load your project but do not run it: 
• Selecting  DSP->Debug from the main window  
• In the Debug dialog, select New to create a new debug configuration  
• Name the configuration and set the project and output file.   
• In the Debugger tab, check the box to Do Not Run after Load  
• Select the Debug button to execute the new configuration 

4. Set a Hardware breakpoint for your G2 target: 
• Select DSP->Hardware Break 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Fill the Core Mapfile field with the appropriate mapfile.  Several are installed 
with IDE; they are located at install directory\zspTools\mapfiles.   

• Set the hardware breakpoint options by selecting the associated checkbox:  
Breakpoint Option Description 
Enable HW Debug Mode Stop target based on hardware condition 
AHB Clock Stop Enable When selected and breakpoint hits, memory is no longer 

accessible by the debugger 
I/O Clock Stop Enable When selected and breakpoint hits, peripherals will be stopped 

 
• Configure the hardware breakpoint type in the dialog: 

Breakpoint Type Description 
External Bit Break occurs for defined external bit 
Instruction Break occurs after instruction executes 
Data Address Break occurs when read / write at defined address; the mask  field is 
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