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Getting Started with BoxView IDE

This quick start guide to BoxView IDE will provide users with steps to using their development
environment: create a simple application, define a debug session, start the simulator, and view project
debug windows. Throughout the following pages, each user step is denoted with a button:

e Sample User Step

A Tutorial and Users Guide are also available within BoxView IDE; access is provided using BoxView IDE
menu option Help->Help Contents.

Development Environment Overview

BoxView Integrated Development Environment (IDE) features the high level language, embedded
processor target debugger as part of the Eclipse software development environment. The Eclipse
platform is an open, industry supported, extensible, software development platform.

e Afterinstalling the product, load BoxView IDE from the desktop.

Several windows are displayed, including a navigator window which shows folders containing sample
projects. There are three basic types of resources that exist in the Development Environment; a resource
is a collective term for the projects, folders, and files viewed in the IDE:

Files Files in the file system

Folders | Directories on a file system. Folders are contained in projects or other folders. Folders
can contain files and other folders.

Projects | Contain folders and files. Projects are used for builds, version management, sharing,
and resource organization. Like folders, projects map to directories in the file system.
(When you create a project, you specify a location for it in the file system.)

The directory location on your computer where the resources will be stored is called a workspace. The
sample projects are stored in the default installed location. The Development Environment supports
multiple workspaces.

e Create a new workspace by selecting File->Switch Workspace... from the main IDE menu.

e Use the Browse button to define the directory that will hold your project files and folders:

g Workspace Launcher @

Select a workspace

BoeMiew IDE skares wour projects in a direckory called a warkspace,
Select the workspace directory o use For this session,

Wotkspace: | BB lRe B ATt L] Browse, ..

(a]'e | Cancel
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Windows in BoxView IDE

The BoxView IDE contains many windows or views. A set of views is called a perspective. The IDE has 2
predefined perspectives: the Project Perspective and the Debug Perspective. The Project Perspective
displays a set of windows valuable when manipulating project files. The Debug Perspective displays
windows valuable when debugging a project. Users can change perspectives by choosing menu option
Window->0pen Perspective or bv usina the associated button on the IDE's button bar:

Choose Perspective
Project Perspective

Debug Perspective

E: BoxView Project - BoxView IDE
Fle Edit Navigate Search Run Project Debug Window Help

g~ e RBMBFES B9 PEE L Fooxviewdebu
G- #-0-Q- =N S i 7 Baview Project

BoxView Projects

Users can add windows to any perspective by using the IDE's Window pull-down menu. Users can close

windows in a perspective by selecting the window's close icon: Close Window

[ welcome 52

Create a Project

The Navigator window provides a hierarchical view of the resources in your workspace; users can open
files for editing by double clicking on the filename in the navigator window.

e Right-click with your mouse in the Navigator to open a pop-up menu that allows operations such
as create new, copy, paste, import, refresh, etc.

e Choose New->Managed Freescale DSP Executable Project:

B BoxView Project - BoxView IDE

File Edit Mavigate Search Run Project Debug Window Help
£~ e (s | REMMLFES ©-0E§E -
HB-0-G- B |
%5 Boodiew Debug | [ Boxview Project
| BE outine 2 . Make Targets | = EI..

An outline is not available,

BoxWiew Projects

I = oot

% Managed ARM Executable Project - ﬁ.

g raste % Managed ARM Static Library Project
| pug Import... % Managed 8051 SDCC Executable Project Resou

3 Expart...

1 ﬂ; Managed Freescale DSP Static Library Project

Y Falder

| File

& | Refresh

|

| [ other... Chrl+H

The New Executable project dialog will be displayed.
Define the new project name in the entryfield; for this example type ExampleProject

e Choose the Finish button.

BoxView IDE Quick Start Guide: Freescale Projects 3



DOMAIN TECHNOLOGIES

The Navigator contains your new project. Use the mouse to double click on the ExampleProject in the
Navigator window. Three files are created automatically by the IDE:

| cdtbuild
| .cdtproject
- project

Create a Source File

Create a source file in your new project that will contain a simple program.

e Select ExampleProject and choose File->New->File from the IDE main menu
o Type simpleExample.asm in the file name entry field.
e Choose the Finish button.
An empty source file named simpleExample.asm has been added and opened in the IDE.

o Fill the simpleExample.asm editor window with the following instructions:

; simpleExample.asm
; Program clears accumulator A, and loops.
; Loop increments A, saves A (A2,A1,A0).

1

org x:0 ; Data block starts at zero
VALUE_A2 dc O ; define storage for A2
VALUE_A1 dc 0 ; define storage for A2
VALUE_AO dc 0 ; define storage for AO

org p:$0000 ; Program block starts at zero
RESET jmp START ; Skip over interrupt vectors

org p:$0100 ;
START clra ;Clear accumulator A

nop ;
LOOP inc a ;Increment A by 1

nop ;

move a2,x:VALUE_A2 ; Save A2

move al x:VALUE_A1 ; Save Al

move a0,x:VALUE_AO ; Save AO

jmp LOOP

; Loop to increment again

end
e Save the simpleExample.asm program by choosing File->Save

Anytime a source file is saved, the automatic build operation will be triggered. Select the Console window
for detail build information results:

Problems B2 L Properties 8 & ¢ EC THm
-Buld [ExampIePro]ect

**%% Tporemental build of configuration Debug for project ExsmpleProject F%%%

c:4BoxViewIDEY pluginshcom. nglogic.boxview.base.vind2_1.0.1.54%02%vin32ix8ehwake all
'Building file: ../simpleExawmple.asm’

msm56300 -g -L -0 -BsimpleExample.cln ../simpleExample.asm

Motorola DSPS56300 LINT Version 6.3.0 04-13-59

Copyright Motorola, Inc. 1993-1998. A4ll rights reserwved.

Motorola D3P56300 Assembler Version 6.3.0

Copyright Motorola, Inc. 159353-1955. All rights reserved.

'Finished building: ../simpleExample.asm'

"

'Building target: ExampleProject.cld’

dzplnk -g -bExampleProject.cld simpleExample.cln

DSP Linker Version 6.3.5

{C) Copyright Motorola, Inc. 1857-1985.
'Finished building: ExampleProject.cld
Build complete for project ExampleProject

A11 rights reserved.
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Configure the Debug Session

Before the debugger can be started, establish a connection to the target hardware and configure the
debug session.

e Open the connection to the target, by choosing menu option Debug->Open Connection or use the
Open Connection button on the IDE's button bar. Choose an embedded processor simulator for
the interface type and press OK to connect:

a' Open HW connection

Interface type:

| sTME6300 -l
Emulator pinaut: C I Initialize on start
{ {+

: fi
£ zep

P

Conneckion
% Direct " TCRiIP
COMILPT # IP address:
o |
IjO Pork # Part #:
Target Seleck: Caunt:

Simulator bvpe is dgfined_ in advanced. .
the debugger configuration
Query | QK | Cancel |

e Change perspectives, to obtain the best views for debugging, by choosing menu option Window-
>0Open Perspective->BoxView Debug or use the BoxView Debug button on the IDE's button bar

e Select from the main menu Run-->Debug

¢ In the Debug session configuration dialog, select DSP Debugger in the Configurations listbox and
choose the New button. The Debug fields on the right pane will be replaced with fields defining a
new session configuration.

e From the Main tab of the Debug configuration dialog, Name the debug session by typing
ExampleProject in the Name entry field.

¢ Fill in the Project entry field by using the Browse button to select ExampleProject

e The Application entry field will be automatically filled in with the output contained in the chosen
project.

e Select the Debugger tab of the Debug configuration dialog

¢ In the Debugger target drop box, define the connection type for the debug session to be Emulator
e Select the Do not run after load checkbox.

e Select the Reset before load checkbox.

e De-select the Stop at main on startup checkbox

e Save the session configuration by selecting the Apply button
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Debugging Your Application

Once the debug session has been configured, the debugger can be started.

e Start your debug session for this named session by selecting the Debug button. Future debug
sessions for this project can be started through the debug icon:

E’ BoxView Debug - simpleExample.asm - BoxView IDE

Eile Edit Mavigate Search Run Project Debug Window Help

- B RE M LFES
G - 3 1.0 -
T} | %5 Boxview Debut
| %5 Debug &2 ] Debug &s 14 E
3&. Debug...

Organize Favarites. ..

Many windows are populated in the Debug perspective when the application is started. In the debug
window, note the application has stopped (as defined in our session configuration):

Resume Atep Into
Terminate Atep Over
%5 Debug 53 e i & | 3D i+ » =0
= [#] exampleProject [DSP Debugger] A
-1 &¥ DSP Debugger {11/16/06 10:30 AM) (Suspended)
= @ Thread [0] (Suspended ) o
< >

The Source window shows an arrow in the margin for the Current Program Counter at the first instruction
in the program. The Code Window shows the Current Program Counter by highlighting in yellow; the
assembler lines representing the Selected Source Line are highlighted in green:

le.asm X 5 || B Mix: simpleExample.asm A& =08
VALUE Az de u] ;ods Jmp STLRT ; Skip Dverj
VALUE_ A1 de a ;od OAFOS0 000100 JHMFP 3TART
WALUE AO de u] :od arg p:i0i00
: - START clr a ; Clear acc
i- e e e e P:000100 200013 CLR A
5 nop
arg p:40000 ] F:000101 000000 NOP
b, FESET Amp STLRET .3 LiooP inc a ; Increment
P:000102 000003 INC A
org p:i0100 in
PEARL sl 2 i & P:000103 000000 HOP
I.mp move az, x:VALTE AZ ; Save AZ
LOGE ine & % P:000104 520000 MOVE  A2,X:d0
nep move al,x:VALUE i1l ; Bave L1
move a2, VALUE_ Az ;3 P:000105 540100 NOVE A1, E:81
move al,x:VALUE A1 ; 3 move a0, x:VALUE A0  ; Save &0
move al,x:VALUE A0  ; 3 P:000106 500200 HOVE A0, X142
Jmp LOOP ; L Jmp LOOP ; Loop to i
end P:O000107 0C0102 JHMP LOOP
: S end
< 5 |

e Set a breakpoint by double clicking in the margin of the source window on the jmp LOOP
instruction.

The source window shows the added breakpoint on the jmp instruction, the code window shows the
breakpoint in burgundy, and the breakpoint window displays the line number of the source file associated
with the breakpoint:
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%¥Debug &2 = O || ® Ereakpoints &2 | Memory ¥:000000 YALUE_AZ =
'3 | 3 D iv - PP EIE N -
= DSP Debugger (12/5/06 10050 AM) (Suspendad) 5 A Di\BoxiewIDEworkspace\ExampleProject|simpleExample .asm [line: 24]
=g Thread [0] (Suspended) v
< %
5 || B mix: simpleExample. asm 5 A& =8
s ~ RESET Jrap START : skip over 4|
[ZALUE 242 de o szl WHEEEGE 0AFO0S0 000100 JHP START
VALUE &1 de o :d g p:$0100
VALUE_20 de o :d STLRT clr a ; Clear acc
; P:000100 200013 CLE A
-------------------------------------- nop
F:000101 000000 NOP
org p:§0000 R LOOF ine =1 ; Increment
> REZET | dmp START ;@ P:000102 DODOOS NG L
org p: 0100 nop
START clr a :C F:000103 000000 HOP
nop move a2, %:VALUE Az ; Bawve AZ
LOCE fari s P P:000104 S5z0000 HOVE hZ, 30
nop HovE al,®:VALUE a1 ; Sawve 4l
e az,%:VALUE AZ . s P:000105 540100 5 HOgiLUE ié;x:sls i
: = : move a0, x: - : Save
meve aé’x:giigz—i; ; : F:000106 500200 MOVE 0, %:52
move oA — 4 Jmp LOOP ; Loop to i
a N Jrap LocH # L 1000107 0CO102 LOOP
end ™ i
< > : =

Memory from the main BoxView IDE Window.

If your debug perspective does not contain a Memory window, add one by selecting Debug ->

If your debug perspective does not contain a Registers window, add one by selecting Debug ->

Registers from the main BoxView IDE Window. Perform a right mouse click in the Registers window
to display the window menu; select the option load registers->56300. Again perform a right click in
the Registers window; select the option Registers Section-> DALU to display the accumulators.

Use the Step Into button of the Debug window (or IDE menu option Run->Step Into) to walk through

the assembler program. Note the register AO value changing and the memory value changing.

Command | Status | Consale || " Mermary ¥:000000 YALUE_A2 &3

AR EH e 2 2 B I

im ﬁRegisters [56300 - regsSE300.xml] £2
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Use the Resume button (or IDE menu option Run->Resume) to hit the breakpoint:

A ﬁa -d;.ﬁx — 0

Qoo00o0 AZ:00 BEO:000000 B1:000000
Q00000 X1:000000 Y0 ;000000 ¥1:000000

e In the Debug window, use the Terminate button (or IDE menu option Run->Terminate) to halt the

execution.

e Choose Debug->Close Connection to close the simulator target hardware connection
For more information on debug windows, review the Debug Menu Options Section of the Users Guide.
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