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Getting Started with BoxView IDE

This quick start guide to BoxView IDE will provide users with steps to using their development environment:
create a simple application, define a debug session, start the simulator, and view project debug windows.
Throughout the following pages, each user step is denoted with a button:

e Sample User Step

A Tutorial and Users Guide are also available within BoxView IDE; access is provided using BoxView IDE
menu option Help->Help Contents.

Development Environment Overview

BoxView Integrated Development Environment (IDE) features the high level language, embedded
processor target debugger as part of the Eclipse software development environment. The Eclipse platform
is an open, industry supported, extensible, software development platform.

e After installing and registering the product, load BoxView IDE from the desktop.

Several windows are displayed, including a navigator window which shows folders containing sample
projects. There are three basic types of resources that exist in the Development Environment; a resource is
a collective term for the projects, folders, and files viewed in the IDE:

Files Files in the file system

Folders Directories on a file system. Folders are contained in projects or other folders.
Folders can contain files and other folders.

Projects | Contain folders and files. Projects are used for builds, version management, sharing,
and resource organization. Like folders, projects map to directories in the file system.
(When you create a project, you specify a location for it in the file system.)

The directory location on your computer where the resources will be stored is called a workspace. The
sample projects are stored in the default installed location. The Development Environment supports multiple
workspaces.

e Create a new workspace by selecting File->Switch Workspace... from the main IDE menu.

* Use the Browse button to define the directory that will hold your project files and folders:

& Workspace Launcher @

Select a workspace

BoxcWiew IDE stores your projects in a directory called a workspace,
Select the workspace directory to use for this session,

[T o[ -1 B | B ViewIDE \workspace LJ Browse. ..

oK | Cancel
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Windows in BoxView IDE

The BoxView IDE contains many windows or views. A set of views is called a perspective. The IDE has 2
predefined perspectives: the Project Perspective and the Debug Perspective. The Project Perspective
displays a set of windows valuable when manipulating project files. The Debug Perspective displays
windows valuable when debugging a project. Users can change perspectives by choosing menu option
Window->Open Perspective or by using the associated button on the IDE's button bar:

Chooze Perspective
Project Perspective

Debug Perspective

Er' BoxView Project - BoxView IDE
Fle Edt Navigate Search Run Project Debug Window Help

E-I0e-  ARMEFES o9 PEE

=l #-O-Q- 8| $0 Bl 5 Boxiew Project

BoxView Projects

Users can add windows to any perspective by using the IDE's Window pull-down menu. Users can close

windows in a perspective by selecting the window's close icon: Close Window

Create a Project

The Navigator window provides a hierarchical view of the resources in your workspace; users can open
files for editing by double clicking on the filename in the navigator window.

¢ Right-click with your mouse in the Navigator to open a pop-up menu that allows operations such as
create new, copy, paste, import, refresh, etc.

e Choose New->Managed 8051 SDCC Executable Project:

E" BoxView Project - BoxView IDE
W Edit Mavigate Search Project Run Debug Window Help

| ™ Project...

Alt+Shift4n  »

% Managed ARM Executable Project
" % Managed ARM Static Library Project

L_‘|'3I.‘| seahis Sk ":i“; Managed 8051 SDCC Executable Project
LE*J ? % Managed Freescale DSP Executable Project
QT.‘%J SEVE St +5hift- % Managed Freescale DSP Static Library Project
RN 1| % Folder
Maove... [ % File
Rename. .. Fz =
Refresh F5 % Other... Cirl+h

The New Executable project dialog will be displayed.

e Define the new project name in the entryfield; for this example type ExampleProject
e Choose the Finish button.
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The Navigator will now contain your new project. Double click on the ExampleProject in the Navigator
window. Three files are created automatically by the IDE and are contained in the project:

=] .cdthuild
- .cdtproject
=| .project

Create a Source File

Create a source file in your new project that will contain a simple program.

e Select ExampleProject and choose File->New->File from the IDE main menu.

The New File dialog will be displayed.

e Type simpleExample.c in the file name entry field.
e Choose the Finish button.

An empty source file named simpleExample.c has been added to the ExampleProject project. The empty
source file is opened in the IDE. Write the content of the new application.

e Fill the simpleExample.c editor window with the following instructions:

int val;
int val2;

int test (int v)

return v * 2;

}
int main(void)

val++;
while (val < 100)

val2 =val/ 2;
val = test(val2);

return O;

}
e Save the simpleExample.c program by choosing File->Save or using the floppy disk icon.

Anytime a source file is saved, the automatic build operation will be triggered.

e Select the Console window for detail build information results:

problems | El consale 22 | Properties 8 4 | #C =
| C-Build [ExampleProject]

w#&*&% Tncremental build of configuration Debug for project ExampleProject W¥#¥

c:\BoxViewIDE\plugins\com.nglogic.boxview.base.win32 1.0.2.56\os\win32\x86\make all

'Building file: ../simpleExample.c'
sdcc_proc —-debug --model-small -mmcs51l -¢ —o simpleExample.rel ../simpleExample.c
'Finished building: ../simpleExample.c’'

'Building target: ExampleProject.out'

sdcc proc —-debug --model-small -out-fmt-ihx -o ExamplsProject.out
sinpleExample.rel

'Finished building: ExampleProject.out’'

Build complete for project ExampleProject
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Configure the Debug Session

Establish a connection to the target hardware and configure the debug session.

e Open the connection to the target, by choosing menu option Debug->Open Connection or use the
Open Connection button on the IDE's button bar. Choose an embedded processor simulator for the
interface type and press OK to connect:

a' Open HW connection

Interface type:
| 5TMB051 x|
Emulator pinout: i1 I Initialize on start
i
: =
' . e
-
Connection
{* Direct " TCPfIP
COM/LPT # IP address:
o |
I/O Port # Port #:
Target Select: Count:
Simulator type is defined in
the debugger configuration Advanced...
Query | OK | Cancel |

e Change perspectives, to obtain the best views for debugging, by choosing menu option Window-
>0pen Perspective->BoxView Debug or use the BoxView Debug button on the IDE's button bar

e Select from the main menu Run-->Debug

¢ Inthe Debug session configuration dialog, select DSP Debugger in the Configurations listbox and
choose the New button. The Debug fields on the right pane will be replaced with fields defining a
new session configuration.

e From the Main tab of the Debug configuration dialog, Name the debug session by typing
ExampleProject in the Name entry field.

e Fillin the Project entry field by using the Browse button to select ExampleProject

e The Application entry field will be automatically filled in with the output contained in the chosen
project.

e Select the Debugger tab of the Debug configuration dialog

¢ Inthe Debugger target drop box, define the connection type for the debug session to be Emulator
e Select the Stop at main() on startup checkbox.

e Save the session configuration by selecting the Apply button
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Debugging Your Application

Once the debug session has been configured, the debugger can be started.

e  Start your debug session for this named session by selecting the Debug button. Future debug
sessions for this project can be started through the debug icon:

B BoxView Debug - simpleExample.c - BoxView IDE

File Edit MNavigate Search Run Project Debug Window Help

£ - s B BRE S TSR
*s G - % 1 -

= :ﬁlBoxView S 3 1 ExampleProject
| %5 Debug 53 Debug As LN R B

.fﬁDebug...

Organize Favorites,..

Many windows are populated in the Debug perspective when the application is started. In the debug
window, note the application has stopped (as defined in our session configuration):

Resume Atep Into
Terminate Btep Cwver
5 Debug 2 1 [ g | B D it -
= ExampleProject [DSP Debugger] A
=l DSP Debugger (1,/29/07 9:53 AM) {Suspended)
=l-gf® Thread [0] (Suspended: Breakpoint hit.) o
= 7 maint =t cimnlaFvamnla -1

L4 >

Below, the Source window shows an arrow in the margin for the Current Program Counter at the first
instruction in the program. The Code Window shows the Current Program Counter by highlighting in yellow;
the assembler lines representing the Selected Source Line are highlighted in green.

[€] simpleExample.c &1 8 ﬂl‘v‘lix: simpleExample.c &2 A iﬁ T,

sasu waaa s

-~ int main(void) j
int teat (int w) * "

£ val++;:

: 05 08 INC val

E4 CLR i

B5 08 02 CJHE A, #008h, 0001Fh

05 0% INC 00S%h

retorn v * 2;

1Nt mainueid) while (val < 100)
i P:001F C3 CLR c
» valtt: P:0020 E5 OF MOV a,val
while (val < 100) P:0022 94 64 SUEE B, #064h
i P:0024 E5 09 MOV B,009n
valz = val / 2: P:0026 64 80 XRL 2, %080n
val = test (vall); P:0028 94 80 SUBE 2,#080n
' P:0022 50 23 JHC 0004Fh
return 0; . {
1 3 valz = val / 2:
P:002C 75 OC 02 MOV _divsint PARM 2, $002h i

e Set a breakpoint by double clicking in the margin of the source window on the val2=val/2
instruction.
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Below the source window shows the added breakpoint on the selected instruction, the code window shows
the breakpoint in burgundy, and the breakpoint window displays the line number of the source file
associated with the breakpoint:

-%Debug £8 e
b S X%BEEG W ~
= ExampleProject [DSP Debugger] wampleProject\simpleExample. c fline: 14]
=1 f-ﬁ’} NED Nahnanar (M1AMN7 0682 AMY fCocnandad)
£
[€] simpleExample.c &2 i} ﬁMix: simpleExample.c &3 A f‘ﬁ ]
10t val; | |
"~ -
int wal2; 0= THe Gaq —i
: ' CLR i
int test (int v) 08 02 CJNE A, $008h,0001Fh
* 09 INC 00%h
retorn v % 2; (val < 100)
H P 001F C3 CLR e
P:0020 E5 08 MOV A,val
int main(wvoid) P:0022 94 64 SUBB A, #064n
i P:0024 ES5 09 MOV A,008n
| val++: P:0026 64 80 XRL A, #080h
while (val < 100) P:0028 94 B0 SUBB A, #080h
{ P:002A 50 23 JHC 0004Fh
@ [line breakpaint: simpleExample. c fline: 14]] {
val = test(val2): n : . 3
) P P divsint PARM 2,#002h
e apasaT P:002F E4 CLR =Y
¥ P:0030 F5 0D MOV 00Dh, &
' = P:0032 85 08 82 MOV DPL,val
e P:0035 85 09 83 MOV DPH, 009 ﬂJ
-

e |f your debug perspective does not contain a Memory window, add one by selecting Debug ->
Memory from the main BoxView IDE Window.

e |f your debug perspective does not contain a Registers window, add one by selecting Debug ->
Registers from the main BoxView IDE Window. Perform a right mouse click in the Registers
window to display the window menu; select the option load registers->8051. Again perform a right
click in the Registers window; select the option Registers Section-> Core to display the core
registers. Once again performing a right click in the Registers window and select the option load
registers->Operand-Hex.

[ Memory D:00 22 B A fﬁ [/E’E et 66 & S ﬂ =Am) gF‘.Egisters [8051 - regs8051,xmi] X

D:00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 a AR &
D:0E 00 06 00 OO0 00 00 00 OO0 00 00 00 00 00 00 [Corel )
D:EC 00 00 00 00 QO 00 00 00 00 00 00 00 00 00 ACC:00 B:0Z PSW:EQ SP:10
D:28 00 00 00 00 QOO 00 OO 00 OO 00 00 00 00 00 DETR: 0000 BPC:0021

D:38 00 00 00 OO0 00 00 0O OO0 OO0 00 OO0 00 00 00 [Operand-Hex]

D:46 00 00 00 00 €O 00 OO0 00 OO 00 00 00 00 00 RO:00 R1:00 RZ:00 R3:00
D:54 00 00 00 OO0 0O 0O OO0 OO0 OO0 00 00 00 00 00 R4:00 R5:00 R6:00 RT:00
D:&2 00 00 00 OO0 00 00 OO0 OO0 OO0 00 00 00 00 00 _1

Connected to the target: Sim8051

e Use the Step Into button of the Debug window (or IDE menu option Run->Step Into) to walk
through the project .

e Use the Resume button (or IDE menu option Run->Resume) to hit the breakpoint

e In the Debug window, use the Terminate button (or IDE menu option Run->Terminate) to halt the
execution.

e Choose Debug->Close Connection to close the simulator target hardware connection

For more information on debug windows, review the Debug Menu Options Section of the Users Guide.
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